A W116 for my daughter's first car?

So I went to look at some cars with Daughter 1 of 3 yesterday. We have this "thing" in our family that our kids need to buy and take care of their own cars, as we did at their stage. She has about $2500 to spend in theory but is being realistic about insurance and having some money set aside for maintenance.

We're still haven't heard from the guy with the bitchin '65 Galaxie 500 (my first choice)

but, considering this Reagan-era German sled on it's own, what do you think of this cosmetically tits 280SE? Since I checked it out, I can append the Hemingway-esque prose of the ad with these additional insights:

Pros:
The car has been obviously well cared for. I'd say garaged all its life based on the very nice paint, zero surface rust and very well-preserved interior. The chrome is all bright and the window seals are not cracked and still pliable. The tires are all 8/10 and I saw minimal evidence of oil leaking on the driveway but nothing noticeable on the the car itself; the engine bay was very, very clean.

The car drove razor straight down the road and the brakes brought the beast to an acceptably quick stop without any drama or noise. It is not fast but neither is it terribly slow. The car's M110 straight-6 put out 143HP new (fucking US-spec) and still feels really good 34 years hence. The slushie shifts butter-smooth and, coupled with the modest HP, the driving experience can best be described as "Stately." All the gizmos inside still work (windows, stereo, door locks and other vacuum-related things that used to drive me nucking futs when I owned my W123).

Cons:
Of course we can't presume a 34 year-old German luxury car selling for less than 2 G's could be perfect. Probably most troubling is the fact that the odometer ist kaput. While the car does not look/feel like a high-miler, the clock checked out at nearly 90K miles. If I had to guess, I'd say it has rolled ~120K miles. Maybe less but I doubt much more. The water temp gage doesn't work but chances are it just needs a new sending unit/sensor. I don't think that's a big deal to fix. The car idles a bit fast, too. That could be a tune up or a vacuum issue or something MAF-related. I guess. The climate control half-works. The AC does not blow cold but she's a teenager, she can live with that. We live in freaking San Diego not Phoenix.

That's really it, AFAIK. Thoughts?